CloudPhone Voicemail Transcription Down
Incident Report for Voxox
Resolved
This incident has been resolved.
Posted 5 months ago. Oct 26, 2018 - 12:03 PDT
Investigating
We're investigating an issue with voicemail transcriptions and working on a resolution. Eligible customers may not receive their voicemail transcription in the meantime.
Posted 5 months ago. Oct 26, 2018 - 09:35 PDT