Calling down for some customers
Incident Report for Voxox
Resolved
Service has been restored.
Posted Jun 16, 2021 - 09:44 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 16, 2021 - 09:30 PDT
Identified
We are investigating an issue prevent calls from connecting for some customers. We will update this page as it is resolved.
Posted Jun 16, 2021 - 07:49 PDT
This incident affected: Cloud Phone (Voice Service), Voxox Business SIP Trunk (Calling Service), and VoxDirect (Voice Service).