Cloud Phone VM Transcription Down
Incident Report for Voxox
Resolved
This incident has been resolved.
Posted 9 months ago. Sep 11, 2018 - 15:38 PDT
Investigating
We are currently investigating this issue.
Posted 9 months ago. Sep 11, 2018 - 14:58 PDT
This incident affected: Cloud Phone (Voice Service).