Cloud Phone - Voice Calling Impairment
Incident Report for Voxox
Resolved
Voxox engineers were able to identify the issue causing some users to experience failed calls on our voice network.
Posted 3 months ago. May 12, 2019 - 21:03 PDT
Investigating
Voxox engineers are currently investing reports of calls failing on the Voxox voice network.
Posted 3 months ago. May 12, 2019 - 20:50 PDT
This incident affected: Cloud Phone (Voice Service).