Voxox Wholesale - Management portal currently unavailable
Incident Report for Voxox
Resolved
This incident has been resolved.
Posted about 1 month ago. Apr 23, 2019 - 12:48 PDT
Investigating
Voxox engineers are currently investigating an issue causing a subset of customers from being able to access their Voxox Wholesale Portal.
Posted about 1 month ago. Apr 23, 2019 - 12:47 PDT
This incident affected: Wholesale Voice (Online Management Portal).