Slow, intermittently failing signups
Incident Report for Voxox
Resolved
This incident has been resolved.
Posted Sep 15, 2020 - 12:39 PDT
Update
This issue should now be resolved, we're continuing to monitor our systems for any additional issues.
Posted Sep 15, 2020 - 12:39 PDT
Identified
We're continuing to address the issue causing slow signups and intermittent failures. We will keep this page updated while working to resolve this fully.
Posted Sep 14, 2020 - 14:38 PDT
This incident affected: Cloud Phone (Online Management Portal) and VoxDirect (Online Management Portal).