Voxox Wholesale Customer Portal Unreachable
Incident Report for Voxox
Resolved
This incident was resolved at 11/10/2022 08:24:47 AM GMT+0
Posted Nov 11, 2022 - 15:44 PST
Investigating
Voxox engineers have received reports that the Voxox Wholesale Portal is unreachable by a subset of customers. Our engineers are currently working on addressing this issue.
Posted Nov 08, 2022 - 09:46 PST
This incident affected: Wholesale Voice (Online Management Portal).