Portal and Calling
Incident Report for Voxox
Resolved
Voxox teams have restored services to affected customers.
Posted Jan 10, 2022 - 08:16 PST
Investigating
Voxox teams are aware of an actively working to resolve an issue impacting calling and portal access for some customers.
Posted Jan 10, 2022 - 07:41 PST
This incident affected: Cloud Phone (Online Management Portal, Voice Service, SMS Service) and VoxDirect (Online Management Portal, Voice Service, SMS Service).