Signup for CloudPhone and VoxDirect temporarily down for maintenance
Incident Report for Voxox
Resolved
CloudPhone and VoxDirect signups are accessible again.
Posted Sep 16, 2020 - 17:34 PDT
Identified
Signup for CloudPhone and VoxDirect is temporarily unavailable while we perform some backend maintenance. We will update this page once services have been restored.
Posted Sep 16, 2020 - 16:21 PDT
This incident affected: Cloud Phone (Online Management Portal) and VoxDirect (Online Management Portal).