CloudPhone time frame not working properly
Incident Report for Voxox
Resolved
This incident has been resolved.
Posted 2 months ago. Mar 11, 2019 - 14:52 PDT
Investigating
We are currently investigating this issue.
Posted 3 months ago. Mar 11, 2019 - 09:59 PDT
This incident affected: Cloud Phone (Online Management Portal).