Hosted PBX - Voicemail Down
Incident Report for Voxox
Resolved
This incident has been resolved.
Posted 4 months ago. Nov 26, 2018 - 13:07 PST
Investigating
We are currently investigating an issue with voicemail on our hosted pbx service.
Posted 4 months ago. Nov 26, 2018 - 12:08 PST
This incident affected: Voxox Business Hosted PBX (Calling Service).