SMS DLR delayed
Incident Report for Voxox
Resolved
This incident has been resolved.
Posted 10 months ago. Nov 09, 2018 - 07:39 PST
Investigating
We are currently investigating this issue.
Posted 10 months ago. Nov 09, 2018 - 07:19 PST
This incident affected: Wholesale SMS (Messages Delivery Receipts (DLR)).