CloudPhone Outbound Calling Impaired
Incident Report for Voxox
Resolved
This incident has been resolved.
Posted 5 months ago. Mar 27, 2019 - 16:21 PDT
Monitoring
Voxox engineers have identified and applied a fix to the affected voice network that impaired calling for CloudPhone customers. They will continue to monitor services to ensure all systems are stable.
Posted 5 months ago. Mar 27, 2019 - 13:03 PDT
Investigating
Voxox engineers are currently investigating reports of impaired outbound calling from the CloudPhone voice network.
Posted 5 months ago. Mar 27, 2019 - 12:39 PDT
This incident affected: Cloud Phone (Voice Service).