Wholesale voice dashboard reflecting inaccurate balances for some customers.
Incident Report for Voxox
Resolved
Issues have been resolved, and dashboards should now accurately reflect balances.
Posted 11 months ago. Sep 11, 2018 - 09:54 PDT
Investigating
Our engineers are investigating an issue with our Wholesale User Portal. Dashboard Balances may be inaccurate in the meantime.
Posted 11 months ago. Sep 10, 2018 - 16:37 PDT
This incident affected: Wholesale Voice (Online Management Portal).