Voxox Office - Lines not registering
Incident Report for Voxox
Resolved
This incident has been resolved.
Posted 8 months ago. Jul 24, 2018 - 12:58 PDT
Investigating
We are currently investigating this issue.
Posted 8 months ago. Jul 24, 2018 - 09:51 PDT
This incident affected: Voxox Office (Calling Service).