Cloud Phone Sign up error and adding a number
Incident Report for Voxox
Resolved
This incident has been resolved
Posted 7 months ago. Oct 16, 2018 - 14:35 PDT
Investigating
We are currently investigating this issue.
Posted 7 months ago. Oct 16, 2018 - 14:33 PDT
This incident affected: Cloud Phone (Online Management Portal).