Wholesale Voice: customers not receiving low balance notifications
Incident Report for Voxox
Resolved
This incident has been resolved.
Posted 4 months ago. May 01, 2019 - 21:44 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 4 months ago. May 01, 2019 - 21:06 PDT