CloudPhone Ring times aren't behaving properly
Incident Report for Voxox
Resolved
This incident has been resolved.
Posted 12 days ago. Mar 13, 2019 - 15:25 PDT
Investigating
We are currently investigating this issue.
Posted 13 days ago. Mar 13, 2019 - 11:54 PDT
This incident affected: Cloud Phone (Voice Service).