Voxox Office: phone registration down for some customers
Incident Report for Voxox
Resolved
This issue was caused by a brief internet outage, and any issues with registration should now be resolved.
Posted 6 months ago. Nov 13, 2018 - 15:14 PST
Investigating
Our engineers have been made aware of an issue with phone registration affecting some of our Voxox Office users. We are investigating now and will update this page as we work towards a resolution.
Posted 6 months ago. Nov 13, 2018 - 14:29 PST