Voxox Office - Registration Impaired
Incident Report for Voxox
Resolved
This incident has been resolved.
Posted 8 months ago. Dec 11, 2018 - 10:36 PST
Update
We are continuing to monitor for any further issues.
Posted 8 months ago. Dec 11, 2018 - 08:44 PST
Monitoring
Our engineers have identified and believe the issue to be resolved, but we are currently monitoring.
Posted 8 months ago. Dec 11, 2018 - 08:44 PST
Investigating
Our team of engineers are currently working on a fix for impaired registration for some of our Voxox Office customers.
Posted 8 months ago. Dec 11, 2018 - 08:27 PST
This incident affected: Voxox Office (Calling Service).