Inbound SMS delayed for some customers
Incident Report for Voxox
Resolved
The issue causing delays with inbound SMS has been resolved.
Posted Nov 17, 2020 - 18:55 PST
Investigating
We are addressing an issue causing delays with inbound SMS for some customers using local numbers. We will update this page as the issue is resolved.
Posted Nov 17, 2020 - 18:28 PST
This incident affected: Cloud Phone (SMS Service) and VoxDirect (SMS Service).