Voxox Office down for some customers
Incident Report for Voxox
Resolved
Systems restored around 8/20/2018 11:00:56 PM.
Posted 9 months ago. Aug 20, 2018 - 23:45 PDT
Investigating
Engineers are investigating a partial outage, possibly caused by an issue with some ISPs.
Posted 9 months ago. Aug 21, 2018 - 00:31 PDT
This incident affected: Voxox Office (Online Management Portal, Calling Service).