Cloud Phone Calling Down
Incident Report for Voxox
Resolved
Services should be fully restored. Please reach out to the Support team if you're still experiencing any issues.
Posted Oct 06, 2019 - 11:08 PDT
Identified
We've identified the issue and services have been partially restored. We're working on resolving the issue completely now.
Posted Oct 06, 2019 - 11:03 PDT
Investigating
We're investigating an issue affecting calling for Cloud Phone, services should be restored shortly.
Posted Oct 06, 2019 - 10:48 PDT
This incident affected: Cloud Phone (Voice Service).