Cloud Phone - Unable to receive faxes
Incident Report for Voxox
Resolved
This incident has been resolved.
Posted Jun 13, 2018 - 15:36 PDT
Investigating
We are currently investigating this issue where Cloud Phone is unable to receive faxes.
Posted Jun 13, 2018 - 13:24 PDT
This incident affected: Cloud Phone (Online Management Portal, Voice Service).