Inbound and Outbound Calling Down for Some CloudPhone Customers
Incident Report for Voxox
Resolved
We have identified and resolved the issue affecting calling for some CloudPhone customers and all services should be restored. Please contact support if any issues persist!
Posted 5 months ago. Dec 27, 2018 - 06:59 PST
Investigating
We are currently investigating an issue affecting calling for CloudPhone, we hope to restore services to all customers shortly.
Posted 5 months ago. Dec 27, 2018 - 06:51 PST
This incident affected: Cloud Phone (Voice Service).