Cloud Phone SMS Down
Incident Report for Voxox
Resolved
This incident has been resolved.
Posted 9 months ago. Sep 07, 2018 - 12:51 PDT
Investigating
We are currently investigating this issue.
Posted 9 months ago. Sep 07, 2018 - 12:32 PDT
This incident affected: Cloud Phone (SMS Service).