Calling down for some customers
Incident Report for Voxox
Resolved
Our engineers have identified the issue and were able to restore all services to optimal voice network conditions.
Posted 7 months ago. Oct 13, 2018 - 10:08 PDT
Investigating
Some Cloud Phone customers have reported to be experiencing issues with making and receiving phone calls over the Cloud Phone network. Engineers are currently working to identify and resolve the issue as quickly as possible.
Posted 7 months ago. Oct 13, 2018 - 09:43 PDT
This incident affected: Cloud Phone (Voice Service).