Wholesale Voice - Delivery Reports delayed for some users
Incident Report for Voxox
Resolved
This incident has been resolved.
Posted 11 months ago. Oct 02, 2018 - 18:03 PDT
Monitoring
Service has been restored, but users may notice short delays with their delivery reports while the archive catches up.
Posted 11 months ago. Oct 01, 2018 - 17:40 PDT
This incident affected: Wholesale Voice (Online Management Portal).