Voxox Customer Support - Chat Support Unavailable
Incident Report for Voxox
Resolved
Voxox teams have been able to resolve all issues related to chat support requests.
Posted Jun 10, 2021 - 17:37 PDT
Identified
Voxox teams are aware of and working to resolve an issue impacting our ability to respond to chat support requests at this time.
Posted Jun 10, 2021 - 15:45 PDT
This incident affected: Voxox Customer Support (Chat).